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JangoMail Tutorial 
Mastering the JangoMail EditLive HTML Editor 

 

With JangoMail, you have the option to use our built-in WYSIWYG HTML Editors to compose 

and send your message.  

 

Note: Please disable any pop up blocker software you are running. Some of the Features 

within JangoMail will pop up guidance or confirmations to you in separate windows.   

 

If you are using an HTML Editor (EditLive, TinyMCE or Simple), you may be prompted for 

brief installations the first time you access the Send Email page on a new machine. Please 

accept / authorize these installations if you are prompted. 

 

You use these Editors much as you would other email or word processing tools. You type 

your text in, and use the tools to format text you select. You also have tools to add the 

other key elements of an HTML email message: links and images. 

 

There are three editors that you can select: Simple, EditLive, and TinyMCE.  

 

The Simple Editor:  

 

 Loads quickly 

 Requires HTML coding 

 

The EditLive Editor:  

 

 Works with any web browser that can run Java applets, PC or Mac 

 Has the option to switch between HTML coding and design 

 Supports cascading style sheets (CSS) 

 Has one-click access to content insertion 

 Has a real-time spell check 

 Allows you to use the whole window space to compose your email 

 Includes Word HTML cleaning options 

 Has selectable Smart Templates 

 Has many more useful features  

 

The TinyMCE Editor: 

 Works much like the EditLive Editor 

 Loads fast 

 Is introduced and explained on our blog 

 

To select the EditLive Editor, go to Messages and then click the + sign to Compose a 

New Message. Then choose how you want to create the message. In this example, we 

choose with a New Blank Message. Click on the  Settings Icon and then choose 

you’re the EditLive HTML editor.  

 

http://blog.jangomail.com/2011/02/html-editor-tinymce-email-marketing.html
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You'll work with the Editor in the Message composition area. If your page does not default 

to the Editor you want, you can use the  Settings Icon to select the HTML Editor.  

 

 
 

Note: You may need to install Java and to allow permission for the component 

(designed by Ephox) to run. If you do not have Administrator privileges, you may 

need your Administrator’s help to allow this initial installation. Once installed, 

your will not need further assistance from your Administrator. 

 

When the Java component is fully loaded, your screen will look like this: 
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Exploring the HTML Editor Window: 

 

You are now ready to use the HTML Editor to compose your message. Let’s explore some 

basics about the Editor Window. 

 

The Editor has its own Menu bar:  

 

 
 

The Editor has four Toolbars:  

 
 

The Editor has a composition area, displaying either Design or Code (as selected by the 

tabs at the bottom of the window).  

 

 
 

You use the Design tab to create your message, and the Editor will write the code needed 

to make your message render properly as HTML on the Code tab. If you want to view your 

source code, you may click the Code tab at any time. You may return to the Design tab by 

clicking the Design tab at any time.  
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Selecting your working window: 

 

The Editor is fully functional within the JangoMail page. If you wish to work within a larger 

screen for easier design, select View, Window View from the Editor’s Menu Bar. This will 

launch the Editor into a window of its own so that you can compose. When you are done 

composing, you may either close this window, or select View, Browser View to return to 

the JangoMail window, with your changes intact. 

 

 
 

Basic composition: 

 

The Editor uses standard word processor composition and formatting tools and commands. 

You may format text by selecting it, then using the appropriate tool. A brief description of 

each standard tool follows. 

 

 Spell Check  

 

 
 

 Manual spell check - Begins a manual review of spelling. 

 Auto spell check - When depressed, red waves indicate misspelled words. 

 

 Cut/Copy/Paste 
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 Cut - Removes selected text to clipboard. 

 Copy - Copies selected text to clipboard. 

 Paste - Pastes clipboard contents where cursor is positioned. 

 

 Format 

 

 
 

 Remove Formatting - Removes all formatting from selected text. 

 Format Painter - Copies format of selected text. Select the text with desired 

formatting, click Format Painter, and then select text to receive the desired 

formatting. The format of the first text selection will be “painted” over the new 

text selection. 

 

 Undo/Redo 

 

 
 

 Edit > Undo - Reverses last action. 

 Edit > Redo - Reverses an Undo. 

 

 Symbol, Horizontal Line 
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 Insert Symbol - Provides pop up window to select symbol characters. 

 Insert Horizontal Rule - Inserts a horizontal ruling line. 

 

 Background Color 

 

 
 

 Background Color - Changes message’s background color. 

 

 Bold, Italics, Underline 

 

 
 

 Bold - Applies bold formatting to selected text. 

 Italics - Applies italics formatting to selected text. 

 Underline - Applies underline to selected text. 
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 Paragraph Formatting 

 

 
 

 Left Alignment - Sets alignment of selected paragraph to left. 

 Center Alignment - Sets alignment of selected paragraph to center. 

 Right Alignment - Sets alignment of selected paragraph to right. 

 

Tip: Pressing Enter always starts a new paragraph, giving the impression of a double 

space. If you want to remain in the same paragraph, but force a new line (single-

spaced), then press Shift+Enter instead. 

 

Tip: To display Paragraph symbols (¶) and line breaks (), then you may use the 

Menu command, View, Show Paragraph Markers. 

 

 
 

 Bullets, Numbering 

 

 
 

 Bullets - Converts selected paragraphs to an unordered list (bullets). 

 Numbering - Converts selected paragraphs to an ordered list (numbers). 

 

 Indentation  
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 Decrease Indent - Decreases indent of selected paragraph. 

 Increase Indent - Increases indent of selected paragraph. 

 

 Text Color 

 

 
 

 Text Highlight - Sets background color for selected text. 

 Font Color - Sets font color for selected text. 

 

 Style, Font, Size 

 

 
 

 Style - Set style for selected text. 

 Font - Set font for selected text. 

 Size - Set size for selected text. 

 

 Tables 
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 Insert Table – Allows you to insert a table to use for alignment of items in your 

page. Often, tables are used to keep text/images in desired alignment. Should 

you wish to "hide" the borders of your table, right click the table after it is 

inserted, select Table Properties, and set the Border Width to zero (0). 

 Insert Row – Allows you to insert a new row within a table. 

 Insert Column – Allows you to insert a new column within a table 

 Split Cell – Allows you to split a cell into multiple rows/columns. 

 Merge Cells – Allows you to combine two cells into one. 

 Show/Hide Gridlines - Allows you to set table gridlines to visible or invisible. 

 

Composing with Hyperlinks: 

 

You may include 3 types of hyperlink (link) within HTML emails: web page link, email link, 

and bookmark link. Once created, you will need to Send or Preview the message to 

yourself to test the links. Links do not actually function within the HTML Editor. 

 

 Web Page Link 

 

 Select the text (or image) to be converted to a link. 

 Select the Insert Hyperlink tool. 

 

 
  

 You will see the Insert Hyperlink window. 

 



JangoMail Enhanced Editor Tutorial – Page 11 of 21 
Evaluating Customers: http://www.jangomail.com/Contact or 1-888-465-2646 
Current Customers: https://www.jangomail.com/Support or 1-888-709-4099 

 
  

 Make sure Existing File or Web Page is selected in the left pane. 

 Type (or paste) the full URL into the Address: bar at the bottom of the window. 

 Click OK. 

 

 Email Address Link 

 

 Select the text (or image) to be converted to a link. 

 Select the Insert Hyperlink tool. 

 

 
  

 Select Email Address in the left pane of the Insert Hyperlink Window. 
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 Type the email address into the Email Address: field. 

 If desired, type a default Subject for the email message into the Subject: field. 

 Click OK. 

 

 Bookmark Link 

 

 Position your cursor at the destination location for your link. You may find it 

easiest to select the first word on the line to which you are linking. This is the 

number “10” in the example below. 
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 Select the Bookmark tool. 

 

 
 

 Type in a name for this location under Bookmark Name and click OK. 
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 You will see the selected location appear with a dotted underscore. This is only 

visible in the browser and will not be seen by your recipients. 

 

 
 

 Now select the text that you want linked to the bookmarked location. In the 

example, this would be the “Click here” text. 

 

 
 

 Select the Insert Hyperlink tool. 
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 Select Places in Document in the left hand pane. 

 

 
 

 Select the named place in this document from the list. In our example, that 

would be "Ten." Click OK. 

 

Composing with Images: 

 

HTML email messages can also include images. Instead of using copy/paste commands to 

insert images into HTML email, however, you will use upload/insert tools. 

 

 Uploading images to the JangoMail Assets Manager 

 

 Navigate to the Assets section of the interface. 
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 Click Add New Item. 

 
 Use the Choose File button to select the JPG, BMP or GIF file from your system. 

You may use any JPG, BMP or GIF file up to 300KB in size. JPG files should be in 

RGB format. 
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 Click Start Upload to upload your image. 
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 When the import is complete, you will see the image appear on the right side of 

the page. 

 
 

 You may continue to import additional images.  When you are done, you may 

return to your message by clicking the Messages tab and clicking the  Edit 

Icon to the right of your message. 

 

 

 Inserting images into your message 

 

 Click to place your cursor in the message where you want the image to be placed.  

 Click the Insert Image tool from the top toolbar. 

 

 
 

 You will open a pop-up window to select your desired image. Make sure you disable 

any pop-up blocker software.  

 

 Select your image from the list of available images. If your image does not appear 

here, make sure it is a JPG, BMP or GIF file type and that you have imported it using 

the Image Manager. JPG files must be in RGB format (not CMYK). 
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 Click OK to place the image in your email. 

 

 
 

 

Composing with Smart Templates: 

 

With the EditLive and TinyMCE HTML Editor, you don't have to start from scratch. You 

can start with a Smart Template, and then modify it.  
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First, there are a few settings you should adjust to get the templates to operate as 

intelligently as possible: 

 

 Assets 

 

 Go to Assets and select Company Logo.  Make sure you designate your 

organization's logo. You can upload your logo into the Assets Manager, then 

copy/paste the URL for the logo into the box provided. To find the location of your 

image, click Your Dedicated Image Folder. Your image URL will be the URL 

provided, followed by the name of your image (i.e. BrownieKitchenLogoSmall.jpg). 

 

 
 

 Using Smart Templates 

 

 Click the Messages main tab and then click Compose New Message. Then choose 

with a JangoMail Smart Template. You will see a list of Smart Templates from 

which to choose, or you can select a Template from within the EditLive or TinyMCE 

Editor. 

 
 After a Smart Template is loaded into the Editor, you can toggle through and 

switch templates with the click of a button. Click Templates to start fresh with a 

different smart template. 
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Note: If you switch templates, any typed content will be lost and replaced by the 

new default template text and placeholders. 


